Skip to main content
  1. Notes/

macOS

Updates App Store apps and install macOS updates #

softwareupdate --install --all

Control Wi-Fi From Terminal #

networksetup -setairportpower "Wi-Fi" on
networksetup -setairportpower "Wi-Fi" off

Flush DNS Cache #

sudo dscacheutil -flushcache
sudo killall -HUP mDNSResponder
sudo killall mDNSResponderHelper

Mount ext4 #

brew cask install osxfuse
brew install ext4fuse

diskutil list

sudo ext4fuse <disk_partition> <where_to_mount> -o allow_other

How to Mount and Access Ext4 Partition in Mac

Use TouchID/Apple Watch for sudo #